RADIUS () — протокол передачі даних що використовується в комп'ютерних мережах для автентифікації, авторизації та обліку різноманітних сервісів (, AAA). RADIUS був розроблений Livingston Enterprises, Inc. в 1991 році, а потім був перенесений в стандарти IETF ().

RADIUS це клієнт-серверний протокол що працює на прикладному рівні, і може використовувати як транспорт як TCP так і UDP.

Стандарти RADIUS визначається наступними стандартами (IETF RFC):

# Назва Дата публікації Пов'язані статті Пов'язані стандарти Коментарі RFC 2058 Remote Authentication Dial In User Service (RADIUS) Січень 1997 RADIUS Obsoleted by RFC 2138 RFC 2059 RADIUS Accounting Січень 1997 RADIUS Obsoleted by RFC 2139 RFC 2138 Remote Authentication Dial In User Service (RADIUS) Квітень 1997 RADIUS Obsoleted by RFC 2865 RFC 2139 RADIUS Accounting Квітень 1997 RADIUS Obsoleted by RFC 2866 RFC 2548 Microsoft Vendor-specific RADIUS Attributes Березень 1999 RADIUS RFC 2607 Proxy Chaining and Policy Implementation in Roaming Червень 1999 RFC 2618 RADIUS Authentication Client MIB Management information base Obsoleted by RFC 4668 RFC 2619 RADIUS Authentication Server MIB Management information base Obsoleted by RFC 4669 RFC 2620 RADIUS Accounting Client MIB Червень 1999 Management information base Obsoleted by RFC 4670 RFC 2621 RADIUS Accounting Server MIB Червень 1999 Management information base Obsoleted by RFC 4671 RFC 2809 Implementation of L2TP Compulsory Tunneling via RADIUS Квітень 2000 RFC 2865 Remote Authentication Dial In User Service (RADIUS) Червень 2000 RADIUS Updated by RFC 2868, RFC 3575, RFC 5080 This standard describes RADIUS authentication and authorization between a Network Access Server (NAS) and a shared RADIUS authentication server. This protocol is also used to carry configuration information from the RADIUS server to the NAS. RFC 2866 RADIUS Accounting Червень 2000 RADIUS This standard describes how accounting information is carried from the NAS to a shared RADIUS accounting server. RFC 2867 RADIUS Accounting Modifications for Tunnel Protocol Support Червень 2000 RADIUS Updates RFC 2866 RFC 2868 RADIUS Attributes for Tunnel Protocol Support Червень 2000 Updates RFC 2865 RFC 2869 RADIUS Extensions Червень 2000 Updated by RFC 3579, RFC 5080 RFC 2882 Network Access Servers Requirements: Extended RADIUS Practices Липень 2000 RFC 3162 RADIUS and IPv6 Серпень 2001 RFC 3575 IANA Considerations for RADIUS Липень 2003 RFC 3576 Dynamic Authorization Extensions to RADIUS Липень 2003 Obsoleted by RFC 5176 RFC 3579 RADIUS Support for EAP Вересень 2003 Extensible Authentication Protocol Updates RFC 2869 RFC 3580 IEEE 802.1X RADIUS Usage Guidelines Вересень 2003 802.1X RFC 4014 RADIUS Attributes Suboption for the DHCP Relay Agent Information Option Лютий 2005 RFC 4372 Chargeable User Identity Січень 2006 RFC 4590 RADIUS Extension for Digest Authentication Липень 2006 Obsoleted by RFC 5090 RFC 4668 RADIUS Authentication Client MIB for IPv6 Серпень 2006 Management information base RFC 4669 RADIUS Authentication Server MIB for IPv6 Серпень 2006 Management information base RFC 4670 RADIUS Accounting Client MIB for IPv6 Серпень 2006 Management information base RFC 4671 RADIUS Accounting Server MIB for IPv6 Серпень 2006 Management information base RFC 4675 RADIUS Attributes for Virtual LAN and Priority Support Вересень 2006 RFC 4679 DSL Forum Vendor-Specific RADIUS Attributes Вересень 2006 RFC 4818 RADIUS Delegated-IPv6-Prefix Attribute Квітень 2007 RFC 4849 RADIUS Filter Rule Attribute Квітень 2007 RFC 5080 Common RADIUS Implementation Issues and Suggested Fixes Грудень 2007 Updates RFC 3579 RFC 5090 RADIUS Extension for Digest Authentication Лютий 2008 RFC 5176 Dynamic Authorization Extensions to RADIUS Січень 2008 RFC 5607 RADIUS Authorization for NAS Management Липень 2009 RFC 5997 Use of Status-Server Packets in the RADIUS Protocol Серпень 2010 Updates RFC 2866 RFC 6158 RADIUS Design Guidelines Березень 2011 RFC 6218 Cisco Vendor-Specific RADIUS Attributes for the Delivery of Keying Material Квітень 2011 RFC 6421 Crypto-Agility Requirements for Remote Authentication Dial-In User Service (RADIUS) Листопад 2011 RFC 6613 RADIUS over TCP Травень 2012 Experimental RFC 6614 Transport Layer Security (TLS) Encryption for RADIUS Травень 2012 Experimental

Див. також Diameter TACACS TACACS+ PPP EAP LDAP FreeRADIUS

Джерела

Посилання Radius Types An Analysis of the RADIUS Authentication Protocol Decoding a Sniffer-trace of RADIUS Transaction Using Wireshark to debug RADIUS