Jetty — вільний контейнер сервлетів, написаний повністю на Java. Може використовуватися як HTTP-сервер або в парі із спеціалізованим HTTP сервером (наприклад, з Apache HTTP Server). Спочатку поширювався під ліцензією Apache 2.0 License, але після переходу в число застосунків, що розробляються в рамках проекту Eclipse (2009) став доступний і під Eclipse Public Licence (EPL).

Jetty використовується деякими іншими популярними проектами, у тому числі серверами застосунків JBoss і Geronimo.

Розробка Jetty зосереджується на створенні простого, ефективного, здатного для упровадження і підключення вебсервера. Малий розмір робить його відповідним для надання послуг вебсервера з вбудованого застосування Java.

У кодовій базі Jetty 7, що перейшла під крило Eclipse, реалізовано специфікації Servlet 2.5 API. Підтримку Servlet 3.0 API додана в Jetty 8. Версії Version Home Java Version Protocols Servlet Version JSP Version Status9.3.xEclipse1.8HTTP/1.1, HTTP/2, WebSocketJSR356, SPDY3.12.3Стабільна9.2.xEclipse1.7HTTP/1.1, WebSocket JSR356, SPDY3.12.3Стабільна 9.1.x Eclipse 1.7 HTTP/1.1 RFC2616, WebSocket JSR356, SPDY 3.1 2.3 Стабільна 9.0.x Eclipse 1.7 HTTP/1.1 RFC2616, WebSocket, SPDY 3.0 (tracking 3.1 drafts) 2.2 Стабільна 8.x Eclipse, Codehaus 1.6 HTTP/1.1 RFC2616, WebSocket, SPDY 3.0 2.1 Стабільна 7.x Eclipse, Codehaus 1.5, J2ME HTTP/1.1 RFC2616, WebSocket, SPDY 2.5 2.1 Стабільна 6.x Codehaus 1.4–1.5 HTTP/1.1 RFC2616 2.5 2.0 Застаріла 5.x Sourceforge 1.2–1.5 HTTP/1.1 RFC2616 2.4 2.0 Застаріла 4.x Sourceforge 1.2, J2ME HTTP/1.1 RFC2616 2.3 1.2 3.x Sourceforge 1.2 HTTP/1.1 RFC2068 2.2 1.1 2.x Mortbay 1.1 HTTP/1.0 RFC1945 2.1 1.0 1.x Mortbay 1.0HTTP/1.0 RFC1945

Джерела

Посилання Домашня сторінка Jetty Офіційні Jetty Wiki eclipse jetty