Ресурсные записи DNS — записи о соответствии имени и служебной информации в системе доменных имён.

В настоящий момент определены следующие типы ресурсных записей (жирным выделены наиболее используемые записи): типрасшифровка названия (англ.)кодописаниеупотребимостьRFCAAddress1адресная запись, соответствие между именем и IP-адресом; только латиница, цифры и дефисодна из самых часто используемых записейRFC 1035A6Address version 6 38адрес в формате IPv6заменена на AAAA из-за чрезмерной сложности в реализации, статус «экспериментальной». RFC 3363, RFC 2874AAAA A+1+1+1 (A использовался для IPv4, AAAA для IPv6) 28адрес в формате IPv6эквивалент А для IPv6; только латиница и дефисRFC 3596AFSDBAFS database18расположение базы данных AFS редкоупотребимая, чаще используется SRV-запись RFC 1183AVCApplication Visibility and Control 258видимость и контроль приложений AVC/avc-completed-templateCAACertification Authority Restriction 257авторизованный центр сертификации RFC 6844CNAMECanonical name5каноническое (альтернативное) имя для псевдонима домена (одноуровневая переадресация); для написания национальными символамишироко используется (но имеет ограничения по применению)RFC 1035Domain Name39псевдоним домена; например, для упрощённой китайской нотации, когда CNAME — на традиционной?RFC 6672DNSKEYDNS Key record48ключ подписи в DNSSEC; формат — как в записи KEYRFC 4034DSDelegation signer43отпечаток (fingerprint) ключа подписи в DNSSECDNSSECRFC 3658GPOSGeographical position27географическое положениеустарела, см LOC RFC 1712HINFOHost Information13информация об узлередкоупотребимаRFC 1035ISDNISDN address20адрес в формате ISDNредкоупотребима (из-за малой популярности сетей ISDN без IP-маршрутизации) RFC 1183KEYPublic key25открытый ключ, используется в DNSSEC малоупотребимаRFC 2535, RFC 3445KXKey Exchanger36??RFC 2230LOCLocation information29географическое местоположение доменаэкспериментальнаяRFC 1876MBMailbox7почтовый ящикредкоупотребима, экспериментальнаRFC 1035MDMail destination3почтовый адресустарелаRFC 1035MFMail forwarder4перенаправление почтыустарелаRFC 1035MGMail group member8номер почтовой группыредкоупотребима, экспериментальнаRFC 1035MINFOMailbox or mailing list information14информация о почтовом ящике или рассылкеэкспериментальнаRFC 1035MRMail rename domain name9?редкоупотребима, экспериментальнаRFC 1035MXMail Exchanger15адрес почтового шлюза для домена: состоит из двух частей — приоритета (чем число больше, тем ниже приоритет), и адреса узлакритически важна для SMTP-протокола, основа маршрутизации почты в ИнтернетеRFC 1035NAPTRNaming authority pointer35указатель на авторитетный узел именования (используется для IP-телефонии)малоупотребима RFC 3263, RFC 3403NULLNull record10пустая записьредкоупотребима, экспериментальнаRFC 1035NSAuthoritative name server2адрес узла, отвечающего за доменную зону: критически важна для функционирования самой системы доменных имёнDNSRFC 1035NSAPNetwork service access point address22указатели в стиле OSIредкоупотребимаRFC 1706NSAP−PTRNSAP pointer23указатель на NSAPустарелаRFC 1348NSECNext-Secure record47часть DNSSEC, подтверждает отсутствие записи; формат — как у NXTDNSSECRFC 4034NSEC3Next-Secure record50расширение DNSSEC, подтверждающее отсутствие записи без возможности просмотра содержимого зоныDNSSECRFC 5155NSEC3PARAMNSEC3 parameters51запись с параметрами для NSEC3DNSSECRFC 5155NXTNext domain30указатель на следующий домен подписанной зоныустарела DNSSECRFC 2065PTRpointer12соответствие адреса — имени: обратное соответствие для A и AAAAшироко используется для IPv4-адресов в домене in-addr.arpa, для IPv6 — в ip6.arpaRFC 1035PXPointer to X.400?указатель на систему маршрутизации почты X.400X.400RFC 822, RFC 2163RPResponsible person17ответственный?RFC 1183RRSIGDNSSEC signature46подпись записи средствами DNSSEC; формат — как у SIGDNSSECRFC 4034RTRoute through21указание на узел, через который следует осуществлять маршрутизациюмалоупотребимаRFC 1183SIGCryptographic public key signature24сигнатура публичной подписималоупотребимаRFC 2931SOAStart of authority6указание на авторитетность информации, используется для указания на новую зонуDNSRFC 1035SPFSender Policy Framework99указывает серверы, которые могут отправлять почту с данного доменадолжна использоваться для SPF-записи, ранее размещавшейся в TXTRFC 7208SRVServer selection33указание на местоположение серверов для сервисовJabber, Active Directory RFC 2782SSHFPSSH Fingerprints44отпечаток ключа SSHмалоупотребимаRFC 4255TKEYTransaction key249метод распространения ключей для TSIG-записей?RFC 2930TLSACertificate association52ресурсная запись DANE?RFC 6698TSIGTransaction signature250идентификация для DNS-операций с использованием общих секретных ключей и хэшейпри передаче зон между DNS-серверамиRFC 2845TXTText string16запись произвольных двоичных данных, до 255 байт в размереSender Policy Framework, DNS-туннели и прочееRFC 1035WKSWell-known service11список доступных общеизвестных сервисов (общеизвестные — с регистрированными номерами портов)?RFC 1035X25PSDN address19адрес в формате X.25редкоупотребимаRFC 1183SVCBService Binding64привязка услуг общего назначения RFC 9460HTTPSHTTPS Binding65SVCB-совместимая ресурсная запись для HTTP(s) RFC 9460

Источники Параметры системы доменных имён (DNS) в IANA

Категория:Интернет-протоколы Категория:DNS