Az RFC (az angol Request For Comments rövidítése, magyarul: ’kéretik megkritizálni’) egy sorszámozott technikai dokumentum, amely az internet és a számítógépes hálózatok működéséhez szükséges szabványokat, protokollokat és eljárásokat írja le. Az új szabvány első tervezete saját számmal kerül a nyilvánosság elé; egy adott időtartamon belül bárki hozzászólhat. Ezeket a hozzászólásokat rendszerezik, majd többszöri módosítás után a szabványtervezetet elfogadják vagy eldobják.
Néhány RFC alkalmazásszintű protokollokat definiál, míg mások sokkal általánosabb témákat. A név eredete a múlt ködébe vész: az 1970-es évek végén, amikor az RFC-k elindultak, még tényleg csak feljegyzések szerepét töltötték be. Azóta a szabványosító szervezet (az IETF) jóval szigorúbban veszi az RFC-k kiadását.
Fontosabb RFC-k RFC 765 File Transfer Protocol (Ftp) RFC 768 User Datagram Protocol (UDP) RFC 791 Internet Protocol (IP) RFC 792 Internet Control Message Protocol (ICMP) RFC 793 Transmission Control Protocol (TCP) RFC 822 Fejléc-, dátum- és időformátumok RFC 826 Address Resolution Protocol (ARP) RFC 903 Reverse Address Resolution Protocol ( RARP) RFC 1034 és RFC 1035 Domain Name System (DNS) RFC 1766, RFC 3066 Tags for the Identification of Languages, RFC 4646, RFC 5646 Tags for Identifying Languages RFC 4647 Matching of Language Tags RFC 1939 Post Office Protocol (POP3) RFC 2068 Hypertext Transfer Protocol (HTTP 1.1) RFC 2821 Simple Mail Transfer Protocol (SMTP)
Vicces nem valós RFC-k Az évek során hagyománnyá vált az április elsejei bolondok napjáról nem valós „RFC”-kkel megemlékezni. Ezek viccesebbjeiből egy válogatás (a teljes műélvezethez némi angoltudás nem árt):
RFC527 ARPAWOCKY RFC748 Telnet RANDOMLY-LOSE option RFC968 Twas the night before start-up RFC1149 A Standard for the transmission of IP datagrams on avian carriers RFC1437 The Extension of MIME Content-Types for a New Medium RFC1605 SONET to Sonnet Translation RFC1882 The 12-Days of Technology Before Christmas RFC1925 The Twelve Networking Truths RFC2324 Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0) RFC2410 The NULL Encryption Algorithm and Its Use With IPSec RFC2549 IP over Avian Carriers with Quality of Service (kiegészítés az RFC1149-hez) RFC2550 Y10K and Beyond RFC2795 The Infinite Monkey Protocol Suite (IMPS) RFC3093 Firewall Enhancement Protocol (FEP) RFC3251 Electricity over IP RFC3514 The Security Flag in the IPv4 Header
Források Hupwiki
Kategória:Internet